Steam Omsi 2 Editor

  • Please note that answers to questions that receive more than 5 collective down votes will be automatically hidden.

DaCookie! // MFF76

Connexions are obviously THE BEST!
Apr 1, 2016
372
Hi,
I've been trying to load the Editor on Steam but to no avail. I do the normal -editor in the set launch options bit and normally works but it's just stopped working. Here is what I mean:
upload_2017-4-1_21-44-48.png
 

Sambob_12

Controlling your content since 2018
Forum Moderator
Content Control
Premium Subscriber
Oct 26, 2016
520
Favourite Truck
Scania
Does it not work if you click OK?
 

Sambob_12

Controlling your content since 2018
Forum Moderator
Content Control
Premium Subscriber
Oct 26, 2016
520
Favourite Truck
Scania
Make sure there's no spaces before or after it
 

DaCookie! // MFF76

Connexions are obviously THE BEST!
Apr 1, 2016
372
Double checked, and nope, it still hasn't worked. I'll restart steam and see what happens.
EDIT: That didn't work either :(
 

Sambob_12

Controlling your content since 2018
Forum Moderator
Content Control
Premium Subscriber
Oct 26, 2016
520
Favourite Truck
Scania
Maybe try restarting the whole computer?
 

wardle man

Well-Known Member
Apr 16, 2016
205
Im getting the same thing now. From looking at google it seams to be something to do with a steam update. I have tried to run as administrator but that was no help and now I am reinstalling steam.
 

DaCookie! // MFF76

Connexions are obviously THE BEST!
Apr 1, 2016
372
Actually, I forgot to say, restarting your computer or shutting it down and turning back on (the latter I did) works and I was able to use editor without any problems! :D
 
  • Like
Reactions: Sambob_12

simulatorguy101

Custom Content Creator
Apr 5, 2016
261
Opening steam and adding in -editor will work. There does not need to be any " " or spaces after editor. Restarting your PC will have little affect is unlikely to work, but GG to you if it did DaCookie. Just delete everything out of the area you put the tag in, press ok and then try again. Putting endless -editor tags on it will just break it even more.
 

Rhys stirling

a B10' lad
May 4, 2016
484
In stead of restarting your pc all you need yo do is load omsi and then load the editor again and it should work that what i do anyway