Pedals (1 Viewer)

  • Please note that answers to questions that receive more than 5 collective down votes will be automatically hidden.

XxGamerDude90xX

Well-Known Member
288
176
Hi, I bought a Logitech driving force gt for omsi. However it will only break when I take my foot off the accelerator pedal. Is there a way that I can change it so that my break pedal will make the bus slow down. It works well on ets 2

Thank you in advance
 

Advertisement

Cauterize1750

#Duuuval
206
263
29
Hi, I bought a Logitech driving force gt for omsi. However it will only break when I take my foot off the accelerator pedal. Is there a way that I can change it so that my break pedal will make the bus slow down. It works well on ets 2

Thank you in advance
You need to go into the settings in Omsi and run a calibration - it sometimes sets it to dual throttle/brake which causes the issue you describe.
In the settings once you’ve calibrated it may sort itself out, if not you can check what peddle is what by pressing it and watching the input window - and configure it how you wish.
 

XxGamerDude90xX

Well-Known Member
288
176
You need to go into the settings in Omsi and run a calibration - it sometimes sets it to dual throttle/brake which causes the issue you describe.
In the settings once you’ve calibrated it may sort itself out, if not you can check what peddle is what by pressing it and watching the input window - and configure it how you wish.
How can I complete the calibration?
 

Road-hog123

An Orange Bus
Administrator
UKDT
Founding Member
1,906
2,709
I think by default the Logitech Profiler is set to report a single axis for throttle and brake, because many games require that to work at all. I would screenshot the option, but the Profiler won't load the configuration page without the wheel plugged in, so it'll have to wait until later when I'm not going to wake everyone up by doing so.
 

Cauterize1750

#Duuuval
206
263
29
So as promised I've posted below a screenshot of my options window for OMSI with my G-29 plugged in, I have had the issue before where it tried to set the Y Axis (Which is my throttle) to have both throttle and brake on it .

First thing I'd suggest is to hit the auto config button and go through it and look to what it brings your settings out as.

If it decides to set a dual control on your throttle, if you try depress your brake pedal and check the input (the bars which show %) to check which axis it is - you should be able to then set it up as your brake and convert the throttle to throttle only, with the boxes to the right of the axis bars.

Hopefully this is of some help - it takes a bit of trial and error to get it right.
1516801333478.png
 

XxGamerDude90xX

Well-Known Member
288
176
So as promised I've posted below a screenshot of my options window for OMSI with my G-29 plugged in, I have had the issue before where it tried to set the Y Axis (Which is my throttle) to have both throttle and brake on it .

First thing I'd suggest is to hit the auto config button and go through it and look to what it brings your settings out as.

If it decides to set a dual control on your throttle, if you try depress your brake pedal and check the input (the bars which show %) to check which axis it is - you should be able to then set it up as your brake and convert the throttle to throttle only, with the boxes to the right of the axis bars.

Hopefully this is of some help - it takes a bit of trial and error to get it right.
View attachment 23832
Thank you however when I try it, I need a clutch however I do not have one
 

Advertisement

58
37
1516819114859.png


These are mine. As you can see that my Brake Pedal is on Axis Y. Yours may be different. However you need to make sure you set that to "Brake" and make a tick in the rev box next to it. Your issue is that the brake pedal is already pressed. This tick in the rev box will reverse that and it should work :)
 

XxGamerDude90xX

Well-Known Member
288
176
View attachment 23841

These are mine. As you can see that my Brake Pedal is on Axis Y. Yours may be different. However you need to make sure you set that to "Brake" and make a tick in the rev box next to it. Your issue is that the brake pedal is already pressed. This tick in the rev box will reverse that and it should work :)
It still hasn't worked :(, but thank you for helping me
 

Advertisement

Road-hog123

An Orange Bus
Administrator
UKDT
Founding Member
1,906
2,709
Go down into your system tray, right click on the Logitech Profiler icon and select "Game Controllers..."
1516827628079.png
Then click "Properties"
1516827693748.png
Then click "Settings"
1516827738999.png
Then make sure that the "Combined" checkbox is unchecked.
1516827781578.png
That should hopefully remedy you problem.
 

XxGamerDude90xX

Well-Known Member
288
176

Members viewing Thread (Users: 0, Guests: 1)