OMSI will not successfully spawn buses

  • Please note that answers to questions that receive more than 5 collective down votes will be automatically hidden.

Lukeyboi

Veteran Member
Apr 5, 2016
712
Hello there,
I have received a severe error within OMSI which means I cannot play it anymore
When I open a map, it runs fine until I spawn a bus

The game will freeze for a bit, then go blank. Occasionally the bus select window pops up, sometimes it doesn't

When it doesnt, I cannot click the bus spawn icon again. It will throw up the "Sichtbares Fenster kann nicht in modales geändert werden" error.

When it does, I can select the bus, but when it spawns the game will freeze and in some cases have severe lighting issues.

While you're enjoying OMSI right now, I'm crying as I can not play it at current. How do you think I feel? I won't get all the amazing mods coming out soon as my OMSI won't take it.

Attached is my logfile from my most recent play, its a Select the Bus/Game Freezes type error

please, I want to start playing OMSI again as soon as possible. I am willing to send my whole OMSI install over (if you are doing this so you can get my maps and repaints I could probably tell who you are so don't try it) if that could help in some form.

Thanks
Luke
 

Attachments

Cauterize1750

#Duuuval
Oct 24, 2016
191
Hi Luke

Looking at your log file, it seems to be having a few issues finding some files

89 21:29:18 - - Warning: Did not find texture file "Text_Field.bmp"!
90 21:29:18 - - Warning: Did not find texture file "Text_Field.bmp"!
91 21:29:18 - - Warning: Did not find texture file "text.bmp"!
92 21:29:18 - - Information: Refresh Tile: 17, maps\Cotterell\tile_3_0.map ...
93 21:29:20 - - Warning: Did not find texture file "TextField.bmp"!
94 21:29:21 - - Warning: Did not find texture file "text.bmp"!
95 21:29:21 - - Information: Refresh Tile: 16, maps\Cotterell\tile_3_1.map ...
96 21:29:21 - - Information: Refresh Tile: 15, maps\Cotterell\tile_3_2.map ...
97 21:29:21 - - Warning: Did not find texture file "Text_Field.bmp"!
98 21:29:21 - - Warning: Did not find texture file "Text_Field.bmp"!
99 21:29:22 - - Information: Refresh Tile: 18, maps\Cotterell\tile_4_0.map ...
100 21:29:22 - - Information: Refresh Tile: 28, maps\Cotterell\tile_4_1.map ...
101 21:29:22 - - Warning: Did not find texture file "front.tga"!
102 21:29:22 - - Warning: Did not find texture file "front.tga"!
103 21:29:22 - - Warning: Did not find texture file "front.tga"!
104 21:29:22 - - Warning: Did not find texture file "front.tga"!
105 21:29:22 - - Warning: Did not find texture file "front.tga"!
106 21:29:22 - - Warning: Did not find texture file "front.tga"!
107 21:29:22 - - Warning: Did not find texture file "front.tga"!
Appears to be where your problem starts in the log file from what I can see

Now I am no expert at this fault finding stuff- but have you tried doing a verify integrity of game cache through steam to see if anything in the core game is missing? sometimes things can be corrupted and it can tend to cause these sorts of issues.

Its a good first step to try, but otherwise I'd consider backing up the Cotterel map along with the buses and repaints and wipe Cotterell and try a fresh install of the map
 

Lukeyboi

Veteran Member
Apr 5, 2016
712
Hi Luke

Looking at your log file, it seems to be having a few issues finding some files



Appears to be where your problem starts in the log file from what I can see

Now I am no expert at this fault finding stuff- but have you tried doing a verify integrity of game cache through steam to see if anything in the core game is missing? sometimes things can be corrupted and it can tend to cause these sorts of issues.

Its a good first step to try, but otherwise I'd consider backing up the Cotterel map along with the buses and repaints and wipe Cotterell and try a fresh install of the map
Hi there,
Its not just Cotterell thats doing this, its with the whole game.
However Verifying the Game found 102 missing files which are being reacquired right now. I dont know how this happened as this install is fairly new.
 

Cauterize1750

#Duuuval
Oct 24, 2016
191
Hi there,
Its not just Cotterell thats doing this, its with the whole game.
However Verifying the Game found 102 missing files which are being reacquired right now. I dont know how this happened as this install is fairly new.
I have had the same issue before with corruptions for some weird reason, not sure what causes it.

Let me know if the 102 missing files fixes it.
 

Road-hog123

An Orange Bus
Administrator
UKDT
Dec 10, 2015
1,772
None of the errors in that logfile are particularly concerning (although I've spotted that there's an error in the public C400RX that I ought to fix), except for the last line:
Warning: Direct3D-Device lost!
This isn't normally concerning because it'll be followed by resetting of the D3D device and Omsi continuing to run, but it seems that hasn't happened. If the verification of Omsi doesn't fix it, I'd suggest this might be a weird problem with DirectX and/or possibly graphics... although I can't be sure because I've never seen this problem before... :tongueout:
 
Last edited:

ABZBuses

Well-Known Member
Apr 1, 2016
223
None of the errors in that logfile are particularly concerning (although I've spotted that there's an error in the public C400RX that I ought to fix), except for the last line:
Warning: Direct3D-Device lost!
This isn't normally concerning because it'll be followed by resetting of the D3D device and Omsi continuing to run, but it seems that hasn't happened. If the verification of Omsi doesn't fix it, I'd suggest this might be a weird problem with DirectX and/or possibly graphics... although I can't be sure because I've never seen this problem before... :tongueout:
I sometimes get that Direct3D error repeatedly with higher depending buses, can take 5 minutes before the bus will spawn.