OMSI Map problems

Status
Not open for further replies.

stevo2882

Well-Known Member
Jun 1, 2016
122
I am having problems with launching a newly created map of my own in OMSI. It launches on OMSI Editor. When I am on OMSI trying to load it. It freezes and crashes and it happens even when I have only put one spline.


Do you know how to sort it?. Because I can get BoTW working
 

whistlehead

Alias Mr Hackenbacker
Staff Team Leader
Forum Moderator
UKDT
Premium Subscriber
Dec 10, 2015
1,377
Post your logfile.txt in a spoiler (press the eyeball button when posting) and then we can see if there are any obvious problems.
 

whistlehead

Alias Mr Hackenbacker
Staff Team Leader
Forum Moderator
UKDT
Premium Subscriber
Dec 10, 2015
1,377
how do you post logfiles?






Either upload it as an attachment (click the choose files button below the post writing box) or open it in Notepad and copy the contents into a spoiler.
 

stevo2882

Well-Known Member
Jun 1, 2016
122
====================

    Start logging

====================


Date:    29/06/2016

Time:    06:59:00

Version: 2.2.032


0 06:59:00 -  -       Information: OMSI is working in fullscreen mode

1 06:59:00 -  -       Information: TIR - looking for DLL path...

2 06:59:00 -  -       Information: TIR  - DLL path not found - TIR disabled [0]

3 06:59:15 -  -       Information: Options dialog created

4 06:59:15 -  -       Information: Weather dialog created

5 06:59:15 -  -       Information: Profiles dialog created

6 06:59:15 -  -       Information: Time table running dialog created

7 06:59:15 -  -       Information: Start dialog created

8 06:59:15 -  -       Information: Menu 2 created

9 06:59:15 -  -       Information: Menu 3 created

10 06:59:15 -  -       Information: Tut dialog created

11 06:59:15 -  -       Information: Menu pos set

12 06:59:15 -  -       Information: Bro initialized

13 06:59:15 -  -       Information: Human engine initialized

14 06:59:15 -  -       Information: Forms set

15 06:59:15 -  -       Information: Captions set

16 06:59:15 -  -       Information: Screen ration set

17 06:59:15 -  -       Information: Init3D: BackBufferFormat = 22

18 06:59:15 -  -       Information: Init3D: Hardware vertex processing

19 06:59:15 -  -       Information: Init3D: Max iso = 16

20 06:59:15 -  -       Information: Init3D: Hal active

21 06:59:16 -  -       Information: Creating 3D device procedure finished

22 06:59:16 -  -       Information: 3D initialized

23 06:59:16 -  -       Information: Direct sound initialized

24 06:59:16 -  -       Information: Create main manager...

25 06:59:16 -  -       Information: Veh array created

26 06:59:16 -  -       Information: CS initialized

27 06:59:16 -  -       Information: Station manager created

28 06:59:16 -  -       Information: OBB created

29 06:59:16 -  -       Information: Tex managers created

30 06:59:16 -  -       Information: Tex manager started

31 06:59:16 -  -       Information: Tutorial manager created

32 06:59:16 -  -       Information: Material manager created

33 06:59:16 -  -       Information: Scenery object manager created

34 06:59:16 -  -       Information: Human manager created

35 06:59:16 -  -       Information: RV type manager created

36 06:59:16 -  -       Information: RV lists created

37 06:59:16 -  -       Information: Spline manager created

38 06:59:16 -  -       Information: Time table manager created

39 06:59:16 -  -       Information: Currency manager created

40 06:59:16 -  -     Warning:       Did not find texture file "30er_reihensiedlung01.bmp"!

41 06:59:16 -  -     Warning:       Did not find texture file "SD_Rad_v.bmp"!

42 06:59:16 -  -     Warning:       Did not find texture file "reifen.bmp"!

43 06:59:16 -  -       Information: Visual helpers created

44 06:59:16 -  -       Information: Audio Mixer erstellen...

45 06:59:16 -  -       Information: ---

46 06:59:16 -  -       Information: Download Internet Textures...

47 06:59:16 -  -       Information: Input Manager erstellen...

48 06:59:16 -  -       Information: Tastaturbefehle laden...

49 06:59:16 -  -       Information: Game Controller laden...

50 06:59:16 -  -       Information: Progman initialisieren...

51 06:59:16 -  -       Information: Partikelvertices initialisieren...

52 06:59:16 -  -       Information: Lichtquellen initialisieren...

53 06:59:16 -  -       Information: System-Scriptvariablen initialisieren...

54 06:59:16 -  -       Information: Redline initialisieren...

55 06:59:16 -  -       Information: Traffic Path Manager initialisieren...

56 06:59:16 -  -       Information: Plugins initialisieren...

57 06:59:16 -  -       Information: Spline-Helper initialisieren...

58 06:59:16 -  -     Warning:       Did not find texture file "path_car_1.bmp"!

59 07:00:07 -  -       Information: Load maps\NewMap\global.cfg map...

60 07:00:07 -  -       Information: Load Cloud and Snowfall objects...

61 07:00:07 -  -     Warning:       Did not find texture file "texture.tga"!

62 07:00:07 -  -     Warning:       Did not find texture file "Snow_1.bmp.001"!

63 07:00:07 -  -       Information: Load Precip. Part. System...

64 07:00:07 -  -       Information: Load Precip. Sound...

65 07:00:07 -  -       Information:    Sound erstellen...

66 07:00:07 -  -       Information:    Sound laden...

67 07:00:07 -  -       Information: Set Weather System vars...

68 07:00:07 -  -       Information: Sky and Weather created

69 07:00:07 -  -       Information: Date: 1988 0809, Time: 062734

70 07:00:10 -  -       Information: Fonts initialized

71 07:00:10 -  -       Information: Map created

72 07:00:11 -  -       Information:   Map Global File loaded

73 07:00:11 -  -       Information:   Registrations loaded

74 07:00:11 -  -       Information:   Parked Cars loaded

75 07:00:11 -  -       Information:   Map AILists loaded

76 07:00:11 -  -       Information:   New Centerkachel set

77 07:00:11 -  -       Information:   VarParents loaded

78 07:00:11 -  -       Information:   Special Objects refreshed

79 07:00:11 -  -       Information:   Object and Spline Matrices refreshed

80 07:00:11 -  -       Information: Map loaded

81 07:00:11 -  -       Information: Humans created

82 07:00:11 -  -       Information: Editor refreshed

83 07:00:11 -  -     Warning:       Cloudtype "-1" could not be found!

84 07:00:11 -  -       Information: Weather loaded

85 07:00:11 -  -       Information: Map camera loaded

86 07:00:11 -  -       Information: maps\NewMap\global.cfg map loaded!

87 07:00:11 -  -     Warning:       Did not find texture file "str_gehweg02.bmp"!

88 07:00:11 -  -     Warning:       Did not find texture file "str_asphdrk_1line.bmp"!

89 07:00:11 -  -     Warning:       Did not find texture file "str_asphdrk_1A.bmp"!

90 07:00:11 -  -     Warning:       Did not find texture file "str_side1.bmp"!

91 07:00:11 -  -       Information: Refresh Tile: 0, maps\NewMap\tile_0_0.map ...

92 07:00:12 -  -     Warning:       Did not find texture file "str_gehweg02.bmp"!

93 07:00:12 -  -     Warning:       Did not find texture file "str_asphdrk_mark1.bmp"!

94 07:00:12 -  -     Warning:       Did not find texture file "str_asphdrk_1line.bmp"!

95 07:00:12 -  -       Information: Refresh Tile: 1, maps\NewMap\tile_0_-1.map ...

96 07:00:12 -  -       Information: Date: 1988 0809, Time: 062734

97 07:00:18 -  -       Information: Traffic loaded

98 07:00:18 -  -       Information: Date: 1988 0809, Time: 062734

99 07:00:18 -  -       Information: Reset Passengers...

100 07:00:18 -  -       Information: Initialize Scheduled AI...

101 07:00:18 -  -       Information: Refresh All Vehicle Indices...

102 07:00:18 -  -     Warning:       Direct3D-Device lost!

103 07:00:18 -  -       Information: Direct3D-Device resetted!

104 07:00:18 -  -       Information: Reset State Matrices...

105 07:00:18 -  -       Information: Start Tex Thread...

106 07:00:18 -  -       Information: Init Red Line...

107 07:00:18 -  -       Information: Set Initial Render States...

108 07:00:18 -  -       Information: Menu pos set

109 07:00:22 -  -     Warning:       Did not find texture file "textfeld_thermo.tga"!

110 07:00:22 -  -     Warning:       Did not find texture file "null.bmp"!

111 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

112 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

113 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

114 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

115 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

116 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

117 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

118 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

119 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

120 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

121 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

122 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

123 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

124 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

125 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

126 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

127 07:00:23 -  -     Warning:       Did not find texture file "null.bmp"!

128 07:00:23 -  -     Warning:       Did not find texture file "IBIS2-Delay_min.tga"!

129 07:00:23 -  -     Warning:       Did not find texture file "IBIS2-Delay_sec.tga"!

130 07:00:23 -  -     Warning:       Did not find texture file "IBIS2-Delay_state.tga"!

131 07:00:23 -  -     Warning:       Did not find texture file "Drucker-Textfeld.tga"!

132 07:00:24 -  -     Warning:       Did not find texture file "LCD-Innenanzeige.bmp"!

133 07:00:42 -  -     Warning:       Did not find texture file "textfeld_thermo.tga"!

 
 

whistlehead

Alias Mr Hackenbacker
Staff Team Leader
Forum Moderator
UKDT
Premium Subscriber
Dec 10, 2015
1,377
It's certainly struggling to load the spline texture files, but I can't tell you much more than that. Does it still open in the editor?


It might also be the fault of "zero-splines", i.e. splines which have a length of zero. I can't remember where in the editor it is, but there's a button you can press that gets rid of all splines of zero length. They can cause a variety of different issues.
 

whistlehead

Alias Mr Hackenbacker
Staff Team Leader
Forum Moderator
UKDT
Premium Subscriber
Dec 10, 2015
1,377
Are you loading the map without buses? It may be trying to load a situation which doesn't exist
 

ross4122

Scottish Vyking Veg
Staff Team Leader
Content Control
Premium Subscriber
Apr 1, 2016
1,011
Leave OMSI alone when it's loading a map. That should help
 

Gh0st28

Guest
Mar 29, 2016
610
Yes as @joe_alker said it's probably the default ailist because all of the buses are active and they can not spawn all at once so that's why it freezes because it's happened to me.
 
Status
Not open for further replies.