Logitech Momo Racing Force - Force Feedback doesn't work anymore

Status
Not open for further replies.
Mar 4, 2015
153
Favourite Truck
DAF
Hello everyone,
I have bought a Logitech Momo Racing Force Feedback from someone half a year ago. It has always worked perfectly fine, but the day before yesterday suddenly the Force Feedback fell away while I was playing a game. Both LED's turned off so I think it doesn't receive any power anymore. My laptop still detects it (USB).
What can I do? Thank you!
 

Seven

The Dickhead
Administrator
Aug 25, 2014
1,436
Favourite Truck
Kenworth
Try reinstalling your drivers.
Failing that, try it in a different computer.
Failing that, try a different power supply.
Failing that, I'm out of ideas! :P
 
Mar 4, 2015
153
Favourite Truck
DAF
Try reinstalling your drivers.
Failing that, try it in a different computer.
Failing that, try a different power supply.
Failing that, I'm out of ideas! :p
The wheel itself works completely fine, it just doesn't get any power. Another power supply doesn't work but I'm not 100% sure if it would work with the Momo. I'll try another one soon!
 

Seven

The Dickhead
Administrator
Aug 25, 2014
1,436
Favourite Truck
Kenworth
The wheel itself works completely fine, it just doesn't get any power. Another power supply doesn't work but I'm not 100% sure if it would work with the Momo. I'll try another one soon!
 

Max

TruckSim.Org Ops Manager
Administrator
Jan 12, 2014
2,205
Favourite Truck
Volvo
The wheel itself works completely fine, it just doesn't get any power. Another power supply doesn't work but I'm not 100% sure if it would work with the Momo. I'll try another one soon!
I don't know if you can even use the Logitech wheels without a power supply (maybe the momo is an exception to that) - definitely try another powersupply, or if you can just check the fuse in the plug of the powersupply you've already got is still intact :)
 
Mar 4, 2015
153
Favourite Truck
DAF
I don't know if you can even use the Logitech wheels without a power supply (maybe the momo is an exception to that) - definitely try another powersupply, or if you can just check the fuse in the plug of the powersupply you've already got is still intact :)
You can, the USB gives enough power for the steer and the pedals. I'll talk with my father later today, me he knows something (like another power cord) :)
 
  • Like
Reactions: Max
Status
Not open for further replies.