Logitech G920 Force feedback issue.

  • Please note that answers to questions that receive more than 5 collective down votes will be automatically hidden.
  • Unfortunately as part of our ongoing site upgrades we have had to remove our support for linking external Steam accounts. If you are unable to login using Steam, please use the username/email address associated with your account to request a new password to login with here.

Nightscape

Member
Mar 15, 2017
68
Hi guys, im trying to use a G920 on OMSI 2 but for the time being i dont want force feedback. I've turned down the settings in OMSI, still get feedback, I've tried changing the steering sensitivity setting in Logitech software, still get feedback. I've noticed when the bus is stopped, the wheel turns just like my Driving Force did, really nice and smooth, as soon as i accelerate the wheel becomes firmer to turn and hitting a curb causes feedback. Oh and enable centering spring setting is not checked.

Is there something im missing or is this an issue with the wheel itself?
 

FirstEnviro

Creator of the E400 MMC and Bristol Airport map.
Nov 1, 2016
486
Hi mate, yeah I know that's what it's meant to do with the feedback but I'm trying to disable the feedback. Tried through the Logitech software, tried through omsi by sliding the sliders all the way down and moved the sliders just a little bit up and force feedback is still on.

Edit: I have found a workout around which is to use the debug exe from the logitech steering wheel SDK to sort the feedback issue, then changing the centering spring to 20% then to 0% makes the steering like it was on my Driving Force Pro, nice and smooth. Just a pain having to do it every time I wanna play OMSi, no issues with other games such as ETS2.
You shouldn't need to do that.

Try this:
Plug in your wheel to the power, load OMSI, check the wheel turns correctly, unplug the wheel from power and then force feedback doesn't work, but main wheel works fine.
 
  • Like
Reactions: Nightscape

FirstEnviro

Creator of the E400 MMC and Bristol Airport map.
Nov 1, 2016
486
Thanks for posting your settings mate. Il try the slider at your settings to see if it helps. So you dont have any issue when you hit a curb, your wheel does suddenly turn and feel weird? Thanks
That's what it's meant to do when you hit a kerb. The wheel isn't meant to be smooth. As you accelerate it becomes harder to steer. If you hit a bump, your wheel shakes a bit, that's just how it is.
 

Nightscape

Member
Mar 15, 2017
68
That's what it's meant to do when you hit a kerb. The wheel isn't meant to be smooth. As you accelerate it becomes harder to steer. If you hit a bump, your wheel shakes a bit, that's just how it is.
Hi mate, yeah I know that's what it's meant to do with the feedback but I'm trying to disable the feedback. Tried through the Logitech software, tried through omsi by sliding the sliders all the way down and moved the sliders just a little bit up and force feedback is still on.

Edit: I have found a workout around which is to use the debug exe from the logitech steering wheel SDK to sort the feedback issue, then changing the centering spring to 20% then to 0% makes the steering like it was on my Driving Force Pro, nice and smooth. Just a pain having to do it every time I wanna play OMSi, no issues with other games such as ETS2.
 

FirstEnviro

Creator of the E400 MMC and Bristol Airport map.
Nov 1, 2016
486
Hi mate, yeah I know that's what it's meant to do with the feedback but I'm trying to disable the feedback. Tried through the Logitech software, tried through omsi by sliding the sliders all the way down and moved the sliders just a little bit up and force feedback is still on.
Just unplug it?
 

Nightscape

Member
Mar 15, 2017
68
You shouldn't need to do that.

Try this:
Plug in your wheel to the power, load OMSI, check the wheel turns correctly, unplug the wheel from power and then force feedback doesn't work, but main wheel works fine.
Yes mate, you legend! That works perfectly. Been bugging me all day. Thanks alot.
 
  • Like
Reactions: FirstEnviro
Top