Help with two rather obscure problems

  • Please note that answers to questions that receive more than 5 collective down votes will be automatically hidden.

Trainman1863

New Member
Mar 12, 2019
4
So I'm fairly new here, and I've been trying to get to grips with OMSI. It's been great, except there are some really big issues that keep cropping up. I have already asked Mr Sylar via Discord, and I was wondering if anybody else might be able to help.

I'm having two other issues (as you might be able to tell, I'm new to OMSI). Issue 1 consists of:
Randomly the bus will stop, it looks like a crash (as in computer crash, not a bus crash), however, the dials are still animated. You can also see ai cars moving around and pedestrians. This is confusing me a lot and I don't know how to fix it. Is it like the jumping bus issue? Or is there a different solution? I get this issue on Cotterell and Farthington demo.

Issue 2 only occurs on farthington (to my knowledge), where i will have an error message saying "Wieso ist das eigene Fahrzeug nicht im Usertrain??", which roughly translates as "Why is not your own vehicle in the Usertrain?"
I have no idea what it means, or how to fix it. I was hoping someone here might know how to fix either of these issues.

To clarify what I've tried:
Turning collisions off
Turning setting all the way down (frame rate is now above 30fps)
Using different buses, it seems less of an issue in the Renown than any other bus (for issues 1 and 2)
I have also tried Googling my issues, to no avail

Thanks in advance
 

The British Gamer

Veteran Member
Dec 29, 2016
1,130
I used to have the same error as you stated in error 1. What I did was just reinstalled Omsi. However, you could try verifying the integrity of your game files via Steam.