General OMSI 2 Help

Status
Not open for further replies.

THE PH6NT0M

Custom Title Space For Rent: £19.99/month
Administrator
UKDT
Dec 10, 2015
532
Hi all,


I was wondering if anyone could spread some light on this error for me? I have mentioned it to fellowslothb before and he hadn't seen it before and up to this point I've been able to 'put up' with it but it is verging on annoying now. A clean install could probably do the trick but I wondered if anyone knew the cause so I wouldn't have to do a clean install. The only maps I've spotted it on so far is Bowdenham V4 and now Keedlestone Dev build. In Bow it tends to happen to the Mercedes not the MANs and in KS its decided to happen to stretches of road...


hPZU_nNJY_Po2ByAbC_dlI8DymABRGRe.jpeg



But as soon as I zoom in ...


hPZU_nNJY_Po2ByAbC_dlI8DymABRGRe.jpeg



Thanks in advance,


Jordan
 
Last edited by a moderator:

sunny2807

Well-Known Member
Feb 12, 2016
329
Hi all,


I was wondering if anyone could spread some light on this error for me? I have mentioned it to fellowslothb before and he hadn't seen it before and up to this point I've been able to 'put up' with it but it is verging on annoying now. A clean install could probably do the trick but I wondered if anyone knew the cause so I wouldn't have to do a clean install. The only maps I've spotted it on so far is Bowdenham V4 and now Keedlestone Dev build. In Bow it tends to happen to the Mercedes not the MANs and in KS its decided to happen to stretches of road...


[...]
This might be helpful: http://www.omnibussimulator.de/forum/index.php?page=Thread&threadID=31348
From what I understand it might be because of lack of memory.
 

THE PH6NT0M

Custom Title Space For Rent: £19.99/month
Administrator
UKDT
Dec 10, 2015
532
Never had this issue before on the maps its just recently appeared but my fear was memory error... 


Pc Specs


8GB Ram 


AMDPhenom II 4x 3.4 Ghz


Nvidia MSI GTX970 4GB


650w PSU


Running OMSI off a 500GB Samsung Evo SSD
 

Lakitu

Prepare for trouble! Make it double!
Content Control
Jan 1, 1970
737
Err, no it shouldn't be a memory error. But this is OMSI we're talking about.


I would check to see if CFF explorer is still applied, if it is, then do a fresh install.
 

THE PH6NT0M

Custom Title Space For Rent: £19.99/month
Administrator
UKDT
Dec 10, 2015
532
Yeah might just have to suck it up and back up the important files and do a fresh install... Gotta just rip the bandage off I guess. Thanks for the help I will do it when im back home after work and let you know if its still happening or not.
 

THE PH6NT0M

Custom Title Space For Rent: £19.99/month
Administrator
UKDT
Dec 10, 2015
532
Yeah I have the 4GB patch installed however im not surr if I bothered with the CFF or not 
 

Lakitu

Prepare for trouble! Make it double!
Content Control
Jan 1, 1970
737
Yeah I have the 4GB patch installed however im not surr if I bothered with the CFF or not 
They both do the same thing, enable 32-bit applications (e.g. OMSI) to access more than 2GB of RAM.
 
  • Like
Reactions: Unitt

Unitt

Member
Mar 26, 2016
51
See with my PC, I don't have that texture bug thing, I just have mad amounts of lag and I'm playing with


AMD 6100 - Six Core


8GB of 1333Mhz Ram ( I need to upgrade this I know )


AMD Radeon 7770 1Ghz


1TB HDD Segate


650W PSU cosair


Windows 10 64x


I've done the 4GB patch and I don't know why I'm still lagging.
 

Lakitu

Prepare for trouble! Make it double!
Content Control
Jan 1, 1970
737
You have too many cores OMSI doesn't like multi core processors.
 

Fellowslothb

Founder of Fellowsfilm Studios
Administrator
UKDT
Dec 10, 2015
639
I don't think its that OMSI doesn't like multi core, it only uses 1 core so if that processor isn't that good with single core processes (AMD processors usually aren't good at those) then it will run like a potato, Have you tried some of the presets for the options? You might be able to get a few more FPS out of OMSI.


For example, I am running an i5-3570k and I don't even have the 4GB patch and I get around 62FPS in Berlin, around 45 in Bowdenham!
 
Last edited by a moderator:
  • Like
Reactions: Admin
D

DVA_MEKA18

Hello All 


Recently i have had a problem with Omsi 2 casuing my PC to restart everytime OMSI crashes 


Can anyone possible suggest a solution  
 
A

Admin

The reason OMSI 2 is crashing could be due to your PC having issues if this is happening. What are your PC's specs?


Also try going to System Properties > Advanced > Startup and Recovery Settings and under "System Failure" there should be a box saying something like "Restart automatically". Uncheck this box, and then when it next happens you'll get an error message telling you what the actual problem is.
 

whistlehead

Alias Mr Hackenbacker
Staff Team Leader
Forum Moderator
UKDT
Premium Subscriber
Dec 10, 2015
1,377
Ok thank you i have now turned that off call me a noob where can i find the Specs 
Go to "My computer" (or "This PC", depending on which version of Windows you use), drop down the top ribbon bar if it isn't already there (little arrow at the top right) and then click "System properties" and either tell us what it says or take a screenshot of it. For instance, my laptop's specs are these:


VhAXGrrc0vSmKRThqhtPYr6eyXKBlK1O.png



This'll help us work out if your computer just isn't powerful enough for OMSI. Things that might help if it isn't are to turn off all background programs (such as internet browsers) and apply NTCore's 4GB patch to the game executable file (Google for the patch)
 
Last edited by a moderator:
D

DVA_MEKA18

Manufactuer: Zoostorm 


Processor: Intel(R) Core(TM) I5-4440 CPU @3.10GHz 3.10 GHz


Installed Memory (RAM): 8.00 GB (7.87 GB Usable)


System Type: 64 bit Operating System, X64- Based Processor 


Pen and Touch: No pen or Touch is Available for this display  
 

whistlehead

Alias Mr Hackenbacker
Staff Team Leader
Forum Moderator
UKDT
Premium Subscriber
Dec 10, 2015
1,377
That should be absolutely fine, it's a reasonably modern Intel processor at over 3GHz and it has more than enough RAM. Hopefully you won't have any other problems.


One thing you can try doing if OMSI is unstable is try verifying the integrity of the game cache. You can do this by going to your Steam library, right clicking on OMSI 2, going to the Local Files tab and clicking "Verify integrity of game cache", in case you didn't already know. A warning though: This will reset all of your options and custom controller inputs, so you might want to copy the Inputs folder and Options.CFG out of the OMSI 2 folder before you do it, so you can put them back afterwards.
 
Status
Not open for further replies.